Войти

Авторизация

Логин:
Пароль:
Забыли пароль?
Регистрация
Сайт пользователей Artisteer и Themler. Официальный торговый представитель.

[РЕШЕНО] работа элемента "поиск по сайту"

Посетитель
Максим
Сообщений: 4
963 дня назад
Столкнулся с проблемой - при добавлении элемента управления "поиск" в шапку сайта (верхний колонтитул) и последующем экспорте в шаблон joomla, поиск на готовом сайте работает без замечаний, но вот если добавить поиск не в шапку, а скажем на боковую панель (макет - виджеты - поиск), то поиск работать отказывается. Кто-нибудь сталкивался с этим?
Постоянный участник
Степаныч
Медаль
Сообщений: 634
6 дней назад
Есть такой косяк. Для исправления нужно открыть файл шаблона ваш_шаблон/data/data.xml

В ближе к концу этого файла найти это:

Код PHP:
  1.  
  2. <![CDATA[<div>
  3. <form action="#" class="art-search" method="get" name="searchform">
  4. <input type="text" value="" name="s" />
  5. <input type="submit" value="Search" name="search" class="art-search-button" />
  6. </form>
  7. </div>]]>
  8.  
и замените на это:

Код PHP:
  1.  
  2. <![CDATA[<div>
  3. <form class="art-search" name="Search" action="/index.php" method="post">
  4. <input type="text" value="" name="searchword" />
  5. <input type="hidden" name="task" value="search" />
  6. <input type="hidden" name="option" value="com_search" />
  7. <input type="submit" value="Search" name="search" class="art-search-button" />
  8. </form>
  9. </div>]]>
  10.  


После этого заново зайти в менеджере шаблонов в этот шаблон и повторить установку контента.
Редактировалось: 1 раз (Последний: 31 октября 2014 в 00:57)
Посетитель
Максим
Сообщений: 4
963 дня назад
Благодарю! Сегодня попробую.
Посетитель
Максим
Сообщений: 4
963 дня назад
Еще раз спасибо, всё работает!
|
Перейти на форум: