Войти

Авторизация

Логин:
Пароль:
Забыли пароль?
Регистрация
Сайт пользователей Artisteer и Themler. Официальный торговый представитель.

Некорректное отражение верхнего меню в верхнем колонтитуле Joomla 2.5

position-30 верхнее меню в вехнем колонтитуле отражается в виде простых ссылок без картинок и эффектов
Посетитель
raykom2010
Сообщений: 4
97 дней назад
Здравствуйте.
Имею Артистер 4.0.0.57793 CMS Joomla 2.7
PHP 5.3

Проблема в том, что в макете имею верхнее меню в заголовке (position-30) в программе отражается корректно со всеми эффектами прозрачности фона и картинок элементов меню, но при установке темплейта на CMS верхнее меню выводится в виде простых ссылок (подчеркнутое название пункта меню)

Подскажите, в чем проблема ?
Спасибо

P.S.
Проблема во всех броузерах
Посетитель
Ivanes
Сообщений: 4
236 дней назад
raykom2010:

Здравствуйте.
Имею Артистер 4.0.0.57793 CMS Joomla 2.7
PHP 5.3

Проблема в том, что в макете имею верхнее меню в заголовке (position-30) в программе отражается корректно со всеми эффектами прозрачности фона и картинок элементов меню, но при установке темплейта на CMS верхнее меню выводится в виде простых ссылок (подчеркнутое название пункта меню)

Подскажите, в чем проблема ?
Спасибо

P.S.
Проблема во всех броузерах

Привет.
Во первых: у тебя не может стоять joomla 2.7, т.к. ее не существует.
Во вторых: для верхнего меню используй position-1 (user 3) а не position-30, и будет тебе счастье...
В третьих: советую почитать
Скрытый текст виден только зарегистрированным пользователям
, на сайте разработчиков
Редактировалось: 3 раза (Последний: 21 сентября 2012 в 04:48)
Посетитель
4inarik
Сообщений: 1
1671 день назад
спасибо добрый человек, помогло
Посетитель
TomSky
Сообщений: 14
65 дней назад
Доброго времени суток! Сделал шаблон в Artisteer 4.2
Экспортировал его в Joomla 2.5.14 которую устанавливал без демо данных. После этого сделал импорт данных как написано
Скрытый текст виден только зарегистрированным пользователям
В результате получил вот такое УГ
Раньше при экспорте все вроде получилось нормально, я уж обрадовался, доработал шаблон, а вышло что опять ничего не вышло... scratch
Постоянный участник
Степаныч
Медаль
Сообщений: 636
3 дня назад
TomSky, а кнопку для импорта контента в самой джумла, в шаблоне нажимали, после установки шаблона.
Ощущение, что у Вас контент просто не установлен.

Здесь видео есть посмотрите, что не так делали:
Скрытый текст виден только зарегистрированным пользователям


Скорее всего забыли установить контент в шаблон.
Посетитель
TomSky
Сообщений: 14
65 дней назад
Степаныч:
а кнопку для импорта контента в самой джумла, в шаблоне нажимали,
Таки нажимал. Правда после импорта под кнопкой выдается какая-то "страшная" надпись о некоей ошибке... Я скриншот позже выложу. Всё с "нуля" попробую сделать и, если не получится буду по порядку скриншоты выкладывать с пояснениями что и когда делал... scratch
Посетитель
TomSky
Сообщений: 14
65 дней назад
Доброго времени суток! Итак, я как и говорил выше "убил" все и начал по новой. Создал БД, пользователя, установил Joomla 2.5.14, установил в нее созданный мной шаблон, перешел как сказано у разработчика и в видеоуроке,в менеджер шаблонов, сделал свой шаблон используемым по умолчанию, зашел в настройки шаблона, провел импорт контента и после импорта опять получил вот такую картинку
, зашел в просмотр сайта и снова все то же УГ

Я вот теперь думаю, может это все дело в шаблоне? Может зря я со старой версии Artisteer слайдер оставил? Или тому виной мое многоуровневое вертикальное меню? А может при создании базы надо было выбрать MySQL а не MySQLi? Вобщем не знаю что и думать...
Модератор Постоянный участник
samson
Медаль За активное участие в жизни сайта.
Сообщений: 916
1 день назад
TomSky, судя по ощибки, попробуйте сделать следущее:

В денвере открыть (В блокноте Notepad++) файл php.ini который находится по адресу

Z:usr/local/php5

И замените в строке ПРИМЕРНО 255 :

Код PHP:
  1.  
  2. max_execution_time = 30;
  3.  
Замените 30 crazy на 120


Artisteer тут не причем, у Вас Денверу не хватает отведенного времени на исполнение... joke
Вероятно получается довольно большой архив с шаблоном.

Поэтому шаблон не устанавливается.
Редактировалось: 1 раз (Последний: 25 августа 2013 в 11:23)
Посетитель
TomSky
Сообщений: 14
65 дней назад
samson:
Замените 30 на 120
Заменил. Даже не на 120, а на 300. Помогло. Спасибо за совет. Работаю дальше. music
Модератор Постоянный участник
samson
Медаль За активное участие в жизни сайта.
Сообщений: 916
1 день назад
TomSky:
Заменил. Даже не на 120, а на 300. Помогло. Спасибо за совет. Работаю дальше.

Хм... Однако проверьте Ваш шаблон на предмет оптимизации изображений.
конечно возможно у Вас просто много контента glasses
Посетитель
TomSky
Сообщений: 14
65 дней назад
samson:
Однако проверьте Ваш шаблон на предмет оптимизации изображений.
За совет спасибо. Это наверняка в слайдере картинки утяжеляют шаблон. А теперь вот ещё какая странность: в шаблоне у меня горизонтальное меню выглядит так:
а после вставки шаблона в Joomla, при нажатии на некоторые пункты, меню на мгновение становится таким:
В макете выбрано меню по ширине листа. Я проверил перед экспортом.
Я погрешил на свою неопытность и сделал шаблон с "нуля" из "дефолтного" шаблона Artisteer-a. Произвел экспорт в Joomla и... снова получил "дергающееся" горизонтальное меню. scratch
Постоянный участник
sagus85
Медаль
Сообщений: 287
6 дней назад
TomSky:
а после вставки шаблона в Joomla, при нажатии на некоторые пункты, меню на мгновение становится таким:

А потом, нормальным делается?
может быть это как раз и прямая зависимость от:

TomSky:
Это наверняка в слайдере картинки утяжеляют шаблон.
Посетитель
TomSky
Сообщений: 14
65 дней назад
sagus85:
может быть это как раз и прямая зависимость от:
картинок в слайдере?
Хорошо. Убрал картинки совсем. Сделал экспорт. Открыл, попробовал покликать по пунктам меню - "дергается". scratch
Возможно в Joomla надо что-нибудь настроить?
Модератор Постоянный участник
samson
Медаль За активное участие в жизни сайта.
Сообщений: 916
1 день назад
TomSky, Адаптивный дизайн при экспорте включен? Попробуйте отключить, экспорт--настройки-- там найдете.
scratch больше пока ничего не приходит, вернее то что на вскидку...
Меню всегда такое или только на время переключения?
Почистите на всякий случай кэш и в джумле и в браузере. Кстати, а такое во всех браузерах?
Посетитель
TomSky
Сообщений: 14
65 дней назад
samson:
Кстати, а такое во всех браузерах?
Как посоветовал уважаемый samson, я сделал другие настройки ширины и проверил работу шаблона во всех имеющихся браузерах. В FireFox, Opera, IE 10, все работает нормально. А вот в Google Chrom, Yandex горизонтальное меню так и продолжает "дергаться". В IE 7,8,9 "дергается" фон сайта. crazy
|
Перейти на форум:
Быстрый ответ
У вас нет прав, чтобы писать на форуме.